# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\|]?[\|]?[ ]?)3193(?:[^\-]*\-){14}([\|]?[\|]?[ ]?)"
test_str = "3189, - , - ,8:30 - 10:45, - , - , - , - , - ,8:30 - 12:00,1:30 - 3:45, - , - , - , - || 3193,8:30 - 12:00,1:30 - 5:00, - ,1:30 - 5:00,9:00 - 12:00,1:30 - 5:00, - , - , - , - , - , - , - , -"
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.