package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9a-zа-яё,]+`)
var str = `sidfgs!"№;%:?*()audбytfsudai,fy76523421746фывпыфпы,фпфып`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}