re = /[0-9a-zа-яё,]+/m
str = 'sidfgs!"№;%:?*()audбytfsudai,fy76523421746фывпыфпы,фпфып'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end