// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9a-zа-яё,]+").unwrap();
let string = "sidfgs!\"№;%:?*()audбytfsudai,fy76523421746фывпыфпы,фпфып";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}