$re = '/[0-9a-zа-яё,]+/m';
$str = 'sidfgs!"№;%:?*()audбytfsudai,fy76523421746фывпыфпы,фпфып';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);