#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=[0-9]\.).*"
Local $sString = "nti" & @CRLF & _
"Gfrfdc ghtfh kmnnm. May24" & @CRLF & _
"1.syed" & @CRLF & _
"2.raja" & @CRLF & _
"3. name3" & @CRLF & _
"4. name4" & @CRLF & _
"5. etc etc" & @CRLF & _
"Vjbvbjb ujytgh" & @CRLF & _
"*sdop gtfd. Nkv" & @CRLF & _
"rti"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")