const regex = /(?=[0-9]\.).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=[0-9]\\.).*', 'gm')
const str = `nti
Gfrfdc ghtfh kmnnm. May24
1.syed
2.raja
3. name3
4. name4
5. etc etc
Vjbvbjb ujytgh
*sdop gtfd. Nkv
rti`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}