import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[0-9]\\.).*";
final String string = "nti\n"
+ "Gfrfdc ghtfh kmnnm. May24\n"
+ "1.syed\n"
+ "2.raja\n"
+ "3. name3\n"
+ "4. name4\n"
+ "5. etc etc\n"
+ "Vjbvbjb ujytgh\n"
+ "*sdop gtfd. Nkv\n"
+ "rti";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}