$re = '/(?=[0-9]\.).*/m';
$str = 'nti
Gfrfdc ghtfh kmnnm. May24
1.syed
2.raja
3. name3
4. name4
5. etc etc
Vjbvbjb ujytgh
*sdop gtfd. Nkv
rti';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);