#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?(DEFINE)" & @CRLF & _
" (?<END>\n?$|\n\n)" & @CRLF & _
" (?<LINE>\n.+)" & @CRLF & _
")" & @CRLF & _
"(?<=...).+(?=...(?&END))" & @CRLF & _
"|..(?=..(?&LINE)(?&END))" & @CRLF & _
"|..(?=.(?&LINE){2}(?&END))" & @CRLF & _
"|..(?=(?&LINE){3}(?&END))" & @CRLF & _
"|(?<=\n..)..(?=.+(?&LINE)(?&END))" & @CRLF & _
"|(?<=\n.)..(?=.+(?&LINE){2}(?&END))" & @CRLF & _
"|(?<=\n)..(?=.+(?&LINE){3}(?&END))" & @CRLF & _
"|(?<=\n....)..(?=.+(?&LINE){4,}(?&END))" & @CRLF & _
"|(?<=^....)..(?=.+(?&LINE){4,}(?&END))" & @CRLF & _
"|..(?=....(?&LINE){4,}(?&END))"
Local $sString = "aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"" & @CRLF & _
"sdaffdsdfsdsfaadd" & @CRLF & _
"afdsafdsfssdsfdfs" & @CRLF & _
"afdsfdssdfdssfdsf" & @CRLF & _
"asfddsfafsdfdsdsf" & @CRLF & _
"asfdsdfafdsafasdf" & @CRLF & _
"" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"hellohellohellohellohello" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")