use strict;
my $str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
';
my $regex = qr/(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.+)
)
(?<=...).+(?=...(?&END))
|..(?=..(?&LINE)(?&END))
|..(?=.(?&LINE){2}(?&END))
|..(?=(?&LINE){3}(?&END))
|(?<=\n..)..(?=.+(?&LINE)(?&END))
|(?<=\n.)..(?=.+(?&LINE){2}(?&END))
|(?<=\n)..(?=.+(?&LINE){3}(?&END))
|(?<=\n....)..(?=.+(?&LINE){4,}(?&END))
|(?<=^....)..(?=.+(?&LINE){4,}(?&END))
|..(?=....(?&LINE){4,}(?&END))/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}