package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.+)
)
(?<=...).+(?=...(?&END))
|..(?=..(?&LINE)(?&END))
|..(?=.(?&LINE){2}(?&END))
|..(?=(?&LINE){3}(?&END))
|(?<=\n..)..(?=.+(?&LINE)(?&END))
|(?<=\n.)..(?=.+(?&LINE){2}(?&END))
|(?<=\n)..(?=.+(?&LINE){3}(?&END))
|(?<=\n....)..(?=.+(?&LINE){4,}(?&END))
|(?<=^....)..(?=.+(?&LINE){4,}(?&END))
|..(?=....(?&LINE){4,}(?&END))`)
var str = `aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}