import Foundation
let pattern = #"""
(?(DEFINE)
(?<END>\n?$|\n\n)
(?<LINE>\n.+)
)
(?<=...).+(?=...(?&END))
|..(?=..(?&LINE)(?&END))
|..(?=.(?&LINE){2}(?&END))
|..(?=(?&LINE){3}(?&END))
|(?<=\n..)..(?=.+(?&LINE)(?&END))
|(?<=\n.)..(?=.+(?&LINE){2}(?&END))
|(?<=\n)..(?=.+(?&LINE){3}(?&END))
|(?<=\n....)..(?=.+(?&LINE){4,}(?&END))
|(?<=^....)..(?=.+(?&LINE){4,}(?&END))
|..(?=....(?&LINE){4,}(?&END))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)