#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<!--(.|\s)*?-->"
Local $sString = "blablabla" & @CRLF & _
                "<teste>teste</teste>" & @CRLF & _
                "etc" & @CRLF & _
                "<!-- Assinatura principal -->" & @CRLF & _
                "<x>mais conteúdo</x>" & @CRLF & _
                "<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->" & @CRLF & _
                "blablabla" & @CRLF & _
                "<!---->" & @CRLF & _
                "<!--" & @CRLF & _
                "-->" & @CRLF & _
                "<p>lorem ipsum</p>" & @CRLF & _
                "<!-- <!-- fad ->----->"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)