re = /<!--(.|\s)*?-->/m
str = 'blablabla
<teste>teste</teste>
etc
<!-- Assinatura principal -->
<x>mais conteúdo</x>
<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->
blablabla
<!---->
<!--
-->
<p>lorem ipsum</p>
<!-- <!-- fad ->----->'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result