use strict;
my $str = 'blablabla
<teste>teste</teste>
etc
<!-- Assinatura principal -->
<x>mais conteúdo</x>
<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->
blablabla
<!---->
<!--
-->
<p>lorem ipsum</p>
<!-- <!-- fad ->----->';
my $regex = qr/<!--(.|\s)*?-->/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";