# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\n(?=(?:(?!START).)*?END)/\n\t/gm;t' <<< "some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify"