const regex = /(?s)\n(?=(?:(?!START).)*?END)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\n(?=(?:(?!START).)*?END)', 'gm')
const str = `some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify`;
const subst = `\n\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);