# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)\n(?=(?:(?!START).)*?END)"
test_str = ("some text to not modify\n"
"some pattern on more than one line START\n"
"text to be indented\n"
"or remove indentation maybe ?\n"
"some pattern on more than one line END\n"
"some text to not modify \n"
"---\n"
"some text to not modify\n"
"some pattern on more than one line START\n"
"text to be indented\n"
"or remove indentation maybe ?\n"
"some pattern on more than one line END\n"
"some text to not modify")
subst = "\\n\\t"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.