$re = '/(?s)\n(?=(?:(?!START).)*?END)/m';
$str = 'some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify';
$subst = "\n\t";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;