$re = '`^([a-z])([a-z\d\-]+)([a-z])$`m';
$str = 'blah
blah-blah
blah-blah34
blah-bl2334sdf
blah-1pass
blah-
-blah
blah_blah';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);