import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?1))*\\K(\\/[^\\/\\n]++)(?=(?1))";
final String string = "/bacon/is/really/good\n"
+ "/is/very/good\n"
+ "/quite/good\n"
+ "pretty/good\n"
+ "good";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}