$re = '/(?:(?1))*\K(\/[^\/\n]++)(?=(?1))/';
$str = '/bacon/is/really/good
/is/very/good
/quite/good
pretty/good
good';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;