use strict;
my $str = '/bacon/is/really/good
/is/very/good
/quite/good
pretty/good
good';
my $regex = qr/(?:(?1))*\K(\/[^\/\n]++)(?=(?1))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";