const regex = /.*\s/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\s', '')
const str = `Veni vidi vici`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);