use strict;
my $str = 'Veni vidi vici';
my $regex = qr/.*\s/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";