#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^\d+]*(?:\+\D*\d+\D+)?(\d{3})\D*(\d{3})\D*(\d{4})\D*$"
Local $sString = "720) 352-6511" & @CRLF & _
"0" & @CRLF & _
"+1 (469) 292-4242" & @CRLF & _
"0" & @CRLF & _
"310.614.1316" & @CRLF & _
"0" & @CRLF & _
"(310) 468-0516" & @CRLF & _
"0"
Local $sSubst = "($1) $2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)