$re = '/^[^\d+]*(?:\+\D*\d+\D+)?(\d{3})\D*(\d{3})\D*(\d{4})\D*$/m';
$str = '720) 352-6511
0
+1 (469) 292-4242
0
310.614.1316
0
(310) 468-0516
0';
$subst = "($1) $2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;