const regex = /^[^\d+]*(?:\+\D*\d+\D+)?(\d{3})\D*(\d{3})\D*(\d{4})\D*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\d+]*(?:\\+\\D*\\d+\\D+)?(\\d{3})\\D*(\\d{3})\\D*(\\d{4})\\D*$', 'gm')
const str = `720) 352-6511
0
+1 (469) 292-4242
0
310.614.1316
0
(310) 468-0516
0`;
const subst = `($1) $2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);