use strict;
my $str = '720) 352-6511
0
+1 (469) 292-4242
0
310.614.1316
0
(310) 468-0516
0';
my $regex = qr/^[^\d+]*(?:\+\D*\d+\D+)?(\d{3})\D*(\d{3})\D*(\d{4})\D*$/mp;
my $subst = '($1) $2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";