#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\u003c\n]*\u003c([^ \u003e]+)[^\-\n]*\-\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+([^ \ ]+)(?:[^\ \n]*\ ){4}([^ ]+)"
Local $sString = "<62>4d19h22m35s:Security: telnet logout by un-authenticated telnet user from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f from USER EXEC mode" & @CRLF & _
"" & @CRLF & _
"<62>2d00h56m15s:Security: SSH login by nirav from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f to PRIVILEGED EXEC mode using RSA as Server Host Key."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")