using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\u003c\n]*\u003c([^ \u003e]+)[^\-\n]*\-\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+\w+\s+([^ \ ]+)(?:[^\ \n]*\ ){4}([^ ]+)";
string input = @"<62>4d19h22m35s:Security: telnet logout by un-authenticated telnet user from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f from USER EXEC mode
<62>2d00h56m15s:Security: SSH login by nirav from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f to PRIVILEGED EXEC mode using RSA as Server Host Key.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}