import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\u003c\\n]*\\u003c([^ \\u003e]+)[^\\-\\n]*\\-\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+\\w+\\s+([^ \\ ]+)(?:[^\\ \\n]*\\ ){4}([^ ]+)";
final String string = "<62>4d19h22m35s:Security: telnet logout by un-authenticated telnet user from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f from USER EXEC mode\n\n"
+ "<62>2d00h56m15s:Security: SSH login by nirav from src IP 192.168.1.229 from src MAC 28d2.44e4.9c8f to PRIVILEGED EXEC mode using RSA as Server Host Key.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}