#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=[*]{60}\/)(\s*\w+(?: \w+\s*)(?=(\((.*?)\)\s*{))).*(\bvar\b([^>=<!;{])*[=]{1}[^=]*?[;])"
Local $sString = "/**********************************************************************functionheaderstuff***********************************************************************************************************************/" & @CRLF & _
"void fn1(void)" & @CRLF & _
"{ " & @CRLF & _
" b= 8;" & @CRLF & _
"}" & @CRLF & _
"/**********************************************************************functionheaderstuff***********************************************************************************************************************/" & @CRLF & _
"void fn2(int a, intb)" & @CRLF & _
"{ int c;" & @CRLF & _
"" & @CRLF & _
" /*var = 6;*/" & @CRLF & _
"}" & @CRLF & _
"/**********************************************************************functionheaderstuff***********************************************************************************************************************/" & @CRLF & _
"void fn3(int a, intb)" & @CRLF & _
"{ int c;" & @CRLF & _
"" & @CRLF & _
" var = 6;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")