const regex = new RegExp('(?<=[*]{60}\\/)(\\s*\\w+(?: \\w+\\s*)(?=(\\((.*?)\\)\\s*{))).*(\\bvar\\b([^>=<!;{])*[=]{1}[^=]*?[;])', 'gms')
const str = `/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn1(void)
{
b= 8;
}
/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn2(int a, intb)
{ int c;
/*var = 6;*/
}
/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn3(int a, intb)
{ int c;
var = 6;
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}