# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=[*]{60}\/)(\s*\w+(?: \w+\s*)(?=(\((.*?)\)\s*{))).*(\bvar\b([^>=<!;{])*[=]{1}[^=]*?[;])"
test_str = ("/**********************************************************************functionheaderstuff***********************************************************************************************************************/\n"
"void fn1(void)\n"
"{ \n"
" b= 8;\n"
"}\n"
"/**********************************************************************functionheaderstuff***********************************************************************************************************************/\n"
"void fn2(int a, intb)\n"
"{ int c;\n\n"
" /*var = 6;*/\n"
"}\n"
"/**********************************************************************functionheaderstuff***********************************************************************************************************************/\n"
"void fn3(int a, intb)\n"
"{ int c;\n\n"
" var = 6;\n"
"}")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.