re = /(?<=[*]{60}\/)(\s*\w+(?: \w+\s*)(?=(\((.*?)\)\s*{))).*(\bvar\b([^>=<!;{])*[=]{1}[^=]*?[;])/m
str = '/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn1(void)
{
b= 8;
}
/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn2(int a, intb)
{ int c;
/*var = 6;*/
}
/**********************************************************************functionheaderstuff***********************************************************************************************************************/
void fn3(int a, intb)
{ int c;
var = 6;
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end