import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!\\w*thing\\b)\\w*ing\\b";
final String string = "everything\n"
+ "running \n"
+ "catching\n"
+ "nothing\n\n"
+ "this is a testing testhing\n\n"
+ "thingaling\n"
+ "blin\n"
+ "123thing";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}