$re = '/\b(?!\w*thing\b)\w*ing\b/m';
$str = 'everything
running
catching
nothing
this is a testing testhing
thingaling
blin
123thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);