import re
regex = re.compile(r"\b(?!\w*thing\b)\w*ing\b", flags=re.MULTILINE)
test_str = ("everything\n"
"running \n"
"catching\n"
"nothing\n\n"
"this is a testing testhing\n\n"
"thingaling\n"
"blin\n"
"123thing")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")