re = /\b(?!\w*thing\b)\w*ing\b/m
str = 'everything
running
catching
nothing
this is a testing testhing
thingaling
blin
123thing'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end