#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<a>[^\s-]+(?:-[^\s-]+)*)-(?<b>[^\s.-]+)\.(?<c>\w+)$"
Local $sString = "id-string1-string2-string3.extension" & @CRLF & _
"" & @CRLF & _
"Il2dK-Ud2d9-Kod2d-d9dwo.jpg" & @CRLF & _
"" & @CRLF & _
"j54fwf3da-7jrg-9eujodww-kio98ujk.png"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")