package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<a>[^\s-]+(?:-[^\s-]+)*)-(?<b>[^\s.-]+)\.(?<c>\w+)$`)
var str = `id-string1-string2-string3.extension
Il2dK-Ud2d9-Kod2d-d9dwo.jpg
j54fwf3da-7jrg-9eujodww-kio98ujk.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}