import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<a>[^\\s-]+(?:-[^\\s-]+)*)-(?<b>[^\\s.-]+)\\.(?<c>\\w+)$";
final String string = "id-string1-string2-string3.extension\n\n"
+ "Il2dK-Ud2d9-Kod2d-d9dwo.jpg\n\n"
+ "j54fwf3da-7jrg-9eujodww-kio98ujk.png";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}