// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<a>[^\s-]+(?:-[^\s-]+)*)-(?<b>[^\s.-]+)\.(?<c>\w+)$").unwrap();
let string = "id-string1-string2-string3.extension
Il2dK-Ud2d9-Kod2d-d9dwo.jpg
j54fwf3da-7jrg-9eujodww-kio98ujk.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}