#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(\p{Lu}+)\h+(.*(?:\R(?!\p{Lu}+\h).*)*)"
Local $sString = "ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан." & @CRLF & _
"FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї." & @CRLF & _
"БАНЉИР انجير آب обе, ки дар он анљири ќоќ" & @CRLF & _
"ва хушкро мељӯшонанд ва он хусусияти" & @CRLF & _
"табобатї дорад." & @CRLF & _
"ӮББАДАЛ بدل آب муовизаи об, табдили об." & @CRLF & _
"ТББАНД بند آب 1. он ки дар пеши об банд ё" & @CRLF & _
"дарѓот месозад. 2. банд, дарѓот." & @CRLF & _
"ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш" & @CRLF & _
"обрўи ошиќи худро зери хавфи коҳиш" & @CRLF & _
"мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар." & @CRLF & _
"ЗББАРДОР آببردار 1. обро ба худ гиранда, он" & @CRLF & _
"чи зиёд об талаб мекунад, обталаб; биринљи" & @CRLF & _
"оббардор. 2. ниг. обчинак." & @CRLF & _
"ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2." & @CRLF & _
"об бардоштани чизе (мас., биринљ)."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")