const regex = /^(\p{Lu}+)\h+(.*(?:\R(?!\p{Lu}+\h).*)*)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\p{Lu}+)\\h+(.*(?:\\R(?!\\p{Lu}+\\h).*)*)', 'gmu')
const str = `ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан.
FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї.
БАНЉИР انجير آب обе, ки дар он анљири ќоќ
ва хушкро мељӯшонанд ва он хусусияти
табобатї дорад.
ӮББАДАЛ بدل آب муовизаи об, табдили об.
ТББАНД بند آب 1. он ки дар пеши об банд ё
дарѓот месозад. 2. банд, дарѓот.
ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш
обрўи ошиќи худро зери хавфи коҳиш
мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар.
ЗББАРДОР آببردار 1. обро ба худ гиранда, он
чи зиёд об талаб мекунад, обталаб; биринљи
оббардор. 2. ниг. обчинак.
ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2.
об бардоштани чизе (мас., биринљ).`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}