import re
regex = re.compile(r"^(\p{Lu}+)\h+(.*(?:\R(?!\p{Lu}+\h).*)*)", flags=re.MULTILINE | re.UNICODE)
test_str = ("ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан.\n"
"FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї.\n"
"БАНЉИР انجير آب обе, ки дар он анљири ќоќ\n"
"ва хушкро мељӯшонанд ва он хусусияти\n"
"табобатї дорад.\n"
"ӮББАДАЛ بدل آب муовизаи об, табдили об.\n"
"ТББАНД بند آب 1. он ки дар пеши об банд ё\n"
"дарѓот месозад. 2. банд, дарѓот.\n"
"ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш\n"
"обрўи ошиќи худро зери хавфи коҳиш\n"
"мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар.\n"
"ЗББАРДОР آببردار 1. обро ба худ гиранда, он\n"
"чи зиёд об талаб мекунад, обталаб; биринљи\n"
"оббардор. 2. ниг. обчинак.\n"
"ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2.\n"
"об бардоштани чизе (мас., биринљ).")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")