import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\p{Lu}+)\\h+(.*(?:\\R(?!\\p{Lu}+\\h).*)*)";
final String string = "ОБАНДОМ آباندام маљ. обпайкар, нозукан- дом, латифбадан.\n"
+ "FБАФКАН آبافكن муњаррики обафкан, даст- гоњи обпошї.\n"
+ "БАНЉИР انجير آب обе, ки дар он анљири ќоќ\n"
+ "ва хушкро мељӯшонанд ва он хусусияти\n"
+ "табобатї дорад.\n"
+ "ӮББАДАЛ بدل آب муовизаи об, табдили об.\n"
+ "ТББАНД بند آب 1. он ки дар пеши об банд ё\n"
+ "дарѓот месозад. 2. банд, дарѓот.\n"
+ "ОББАР بر آب 1. он ки об мебарад, обкаш, маш- коб. 2. маљ. маъшуќ, ки тавассути њуснаш\n"
+ "обрўи ошиќи худро зери хавфи коҳиш\n"
+ "мегузорад. 3. тех. облўла, лўлаи обрасонї, ќубури обгузар.\n"
+ "ЗББАРДОР آببردار 1. обро ба худ гиранда, он\n"
+ "чи зиёд об талаб мекунад, обталаб; биринљи\n"
+ "оббардор. 2. ниг. обчинак.\n"
+ "ҚББАРДОРЇ آببرداري 1. обкашї, машкобї. 2.\n"
+ "об бардоштани чизе (мас., биринљ).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}