package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*\*![^*]*\*+(?:[^\/*][^*]*\*+)*\/`)
var str = `/**!
* Plugin Name 1.0.0
* @author Name
*/
/*! Test */
/* Test */
/************************************************************************/
/******/ /* Test */
/******/
/*!*********************!*\
!*** ./index.ts ***!
\*********************/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}